Shopping Assistance
Finding Products
Exploring Products
Using the Cart
Checking Out
Returns


Payment Methods
Express Accounts
Warranties/Rebates



Contact Us

Secure Certificates

If you are experiencing problems conducting transactions on this site, you may simply need to upgrade your Netscape or Microsoft browsers. This upgrade is necessary because of the expiration on 12/31/99 of your browser's digital certificate, which allows you to conduct a secure online transaction. If, in the process of moving to the Frys.com checkout, you see a box that indicates that your browser is not secure, be assured that your transaction is indeed a secure one. Users of Internet Explorer 4.5 or older need to upgrade their browsers to IE 4.51, which they can do at Microsoft. (More information is available .) Users of Netscape Navigator or Composer (4.06 or older) can either obtain free upgrades at Netscape's Homepage or order a CD-ROM (For more information, visit Netscape.)
Once you have successfully updated your browser, you can then proceed with your secure online transaction at Frys.com. We're sorry for the inconvenience.